Can I make AllenNLP compatible with my NVIDIA Driver(in other words, CUDA8.0 or CUDA9.0)?

  • OS: Linux x86_64
  • NVIDIA Driver version : 384.130(seems like only supporting cuda9.0 or lower )
  • Python version: 3.6.1
  • AllenNLP version: 0.9.0 (use pip install allennlp)
  • PyTorch version: 1.0.1 (Before I install AllenNLP, I use conda install pytorch==1.0.1 torchvision==0.2.2 cudatoolkit=8.0 -c pytorch to install PyTorch)

Q: Can I make AllenNLP compatible with my NVIDIA Driver(in other words, CUDA8.0 or CUDA9.0)?

It seems that AllenNLP(0.9.0) requires torch >= 1.2.0, which requires cuda>=9.2. But my driver seems to only supporting cuda9.0 or lower , and the driver now can’t be updated.
I wonder if I can install old version of AllenNLP to make it compatible with cuda9.0? How to do this with pip?
Note: I install AllenNLP to use pre-trained ELMo, so the old version should include ELMO
Thank you very much~